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Course Agenda
Day 1

Agenda & Introduction

Training Modules:g

1. Model Structure & Inputs, TreeAge Pro Application Interface

2. Build a Cost-Effectiveness Model

• Variables, Formula Editor, Clones

3. Roll Back, Cost-Effectiveness Analysis
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4. Deterministic Sensitivity Analysis

• Modeling Exercise

5. Monte Carlo Simulation and Probabilistic Sensitivity Analysis
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Course Agenda

Day 2

Training Modules:

6. Markov Models

7. Markov Models & Time Dependence

8. Microsimulation

9 Microsimulation – Decisions & PSA
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9. Microsimulation Decisions & PSA

10. Microsimulation Advanced Techniques

11. Extras

TreeAge Pro Healthcare Training

Introduction

• What is TreeAge Pro?
• Visual tool for building and analyzing models

• Model types:
D i i t M k d l b th• Decision trees, Markov models, both

• Analysis features:
• Expected Value calculations:

• Roll back, cost-effectiveness analysis, Markov Cohort analysis, 
etc.

• Sensitivity analysis:
• Deterministic and probabilistic

4

• Monte Carlo simulation:
• PSA (sampling), Microsimulation (trials), both, EVPPI

TreeAge Pro Healthcare Training
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Introduction

• Why use TreeAge Pro?
• Create models to represent a disease process and possible 

treatment options

• Built in healthcare modeling analysis and reporting features• Built-in healthcare modeling, analysis and reporting features

• Compare treatment options on the basis of cost, 
effectiveness or both

• Measure effects of uncertainty on treatment strategy 
selection

• Build models of nearly unlimited complexity and size

• Visual tool:

5

• Visual tool:
• Efficient to build and modify models

• Clear when presenting/sharing models

TreeAge Pro Healthcare Training

Model Structure & Inputs, TP User Interface

Module Agenda:

1. Examine model structure and inputs

2. Introduce the TreeAge Pro User Interface

6TreeAge Pro Healthcare Training – Module 1
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Model Structure & Inputs

• Model structure is comprised of a collection of nodes

• Root node:
• Every model starts at the left with a single node

• Frequently a decision node

• Decision nodes:
• Branches are alternative strategies

• Value of each alternative is calculated independently

7

Value of each alternative is calculated independently

• Analysis chooses optimal path/strategy at every decision 
node

TreeAge Pro Healthcare Training – Module 1

Model Structure & Inputs

• Chance nodes:
• Branches are possible outcomes

• Probabilities are associated with each branch
M t ll l i d h ti (“ h ”)• Mutually exclusive and exhaustive (“coherence”)

• Sum of probabilities = 100%

• Use “#” for complement

• Terminal nodes:
• Complete the scenario (root to terminal node)

8

• Payoffs place a value on all events within that scenario

• Different for Markov models

TreeAge Pro Healthcare Training – Module 1
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Model Structure & Inputs

Decision node Chance nodes Terminal nodes

Probabilities PayoffsRoot node Strategies

9TreeAge Pro Healthcare Training – Module 1

Example01-Intro.trex

Model Structure & Inputs

• Model numeric expressions:
• Required for probabilities, payoffs, Markov rewards, etc.

• Consist of any combination of numbers, model inputs, built-
in functions and operatorsin functions and operators

• Model inputs:
• Variables: named values

• Trackers: named values  associated with Microsimulation 
trials

• Distributions: sampled for Monte Carlo simulation

10

• Distributions: sampled for Monte Carlo simulation

• Tables: grids of values

• Tree preferences:
• Control the calculation and display of a model

TreeAge Pro Healthcare Training – Module 1
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TreeAge Pro User Interface
Tree Diagram Editor Perspectives

11TreeAge Pro Healthcare Training – Module 1

Projects View Model Input Views

TreeAge Pro User Interface

• Tree Diagram Editor
• Primary modeling window

• Tabs for multiple models or multiple views of a single model

Z i / t lti l t t b• Zoom in/out, multi-select, noteboxes

• Views
• For editing/viewing components of the model

• Open via Views toolbar list

• Move, maximize, minimize, detach

• Perspectives

12

p
• Collection of views’ orientation stored when you exit 

software

• Can reset to original orientation or overwrite saved 
orientation

TreeAge Pro Healthcare Training – Module 1
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TreeAge Pro User Interface

• Model Input Views:
• Specific view for each model input

• Some tied to tree (e.g., tree properties, variable properties)

S ti d t d ( d ti i bl• Some tied to node (e.g., node properties, variable 
definitions)

• Many more

• Other Views:
• Projects View for managing files

13

• Model Overview/Tree Explorer for navigating in large trees

• Evaluator for testing calculations

• Context-sensitive help

• Many more

TreeAge Pro Healthcare Training – Module 1

Build CE Model, Variables, Tree Preferences

Module Agenda:

1. Build a Cost-Effectiveness (CE) Model

2. Create and Use Variables

3. Formula Editor/AutoFill

4 Edit T P f

14

4. Edit Tree Preferences

5. Introduce Clones

• Finally, the training becomes interactive!!!
TreeAge Pro Healthcare Training – Module 2
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Build CE Model

• Determining numeric values:
• All the numeric values you need for this model will be 

provided

• In your models considerable thought will go into• In your models, considerable thought will go into 
determining each value

• Some will come from medical literature

• Some will come from trials

• Some must be estimated

• Etc.

15

• TreeAge Pro cannot determine these values for you

TreeAge Pro Healthcare Training – Module 2

Build CE Model

• The current standard is to treat a specific type of tumor 
with radiation

• We want to study a new treatment that combines surgery 
and radiationand radiation

• We estimate that the new treatment will increase the 
probability of eradicating the tumor from 60% to 80%

• A person’s life expectancy is 10 years if the tumor is 
eradicated, but only 3 years if not

• The costs associated with radiation and surgery are $30K 

16

and $50K respectively

• The follow-up costs post-treatment are $2K per year

TreeAge Pro Healthcare Training – Module 2
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Build CE Model

• How do we create a model from the information provided?
• We will look at each piece of information as we build the tree

• Information:
• The current standard is to treat a specific type of tumor with 

radiation

• We want to study a new treatment that combines surgery 
and radiation

17

• Model:
• Root node is decision with two branches for treatment 

options

TreeAge Pro Healthcare Training – Module 2

Build CE Model

Instructions:

1. Create new model from toolbar icon (blank tree).

2. Drag Decision node from palette to Tree Diagram Editor.

3. Enter node label text.

4. Double-click on root node to add two branches.

5. Enter node label text for each strategy.

6. Adjust width of node as desired for text formatting.

18TreeAge Pro Healthcare Training – Module 2
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Build CE Model

• Information:
• We estimate that the new treatment will increase the 

probability of eradicating the tumor from 60% to 80%

• Model:
• Both strategies are chance nodes with branches for tumor 

eradicated or tumor not eradicated

• Different probabilities for each set of branches

19TreeAge Pro Healthcare Training – Module 2

Build CE Model

Instructions:

1. Double-click on top strategy node to add two branches.

2. Enter node labels.

3. Enter the probability of eradicating tumor under that 
branch (60% or 0.6 for standard treatment).

4. Enter the complement character (#) under the other 
branch.

5. Ignore the bottom strategy for now; we will create it later.

20TreeAge Pro Healthcare Training – Module 2
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Build CE Model

• Information:
• A person’s life expectancy is 10 years if the tumor is 

eradicated, but only 3 years if not

• The costs associated with radiation and surgery are $30K• The costs associated with radiation and surgery are $30K 
and $50K respectively

• The follow-up costs post-treatment are $2K per year

• Model:
• Each of these numeric values factors into the payoffs 

( i l )

21

(scenario values)

• However, since they are used in multiple payoffs, it is best to 
use variables rather than enter the values directly

• We will break from building the model to discuss variables

TreeAge Pro Healthcare Training – Module 2

Variables

• Variables are named values like in algebra

• A variable has a…
N d f t th i bl ’ l• Name: used as a reference to the variable’s value

• Definition: provides a new value for the variable

• Benefits
• Transparency - easier for you and your colleagues to 

understand the meaning of numbers inside a model

22

• Efficiency – changing a single variable can affect multiple 
numeric expressions in the model

• Consistency – define once use many times

• Sensitivity analysis – covered later

• Clones – covered later

TreeAge Pro Healthcare Training – Module 2
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Variables

• Variable definitions:
• Variables are defined at a specific node, so a variable can 

have a different value for different parts of the model

• Definition scope is from definition node to the right• Definition scope is from definition node to the right

• Shown beneath node in box 
(to distinguish from probabilities)

• Useful for clones – covered later

• Variable and other input names:

23

• 32 letters/numbers/underscores (no punctuation)

• Stick to a naming style/convention

• Not case sensitive

• Now… back to the model!
TreeAge Pro Healthcare Training – Module 2

Build CE Model

Instructions:

1. Right-click on root node and choose Define Variable > 
New Variable from the context menu.

2 E i bl “ F ll A l”2. Enter variable name “cFollowupAnnual”.

3. Enter a description and comment if desired.

4. Click OK.

5. Enter definition “2K” in the Define Variable dialog and 
click OK.

6 You will see the variable definition beneath the root node

24

6. You will see the variable definition beneath the root node.

7. Repeat steps 2-5 for the variables below.
• cRadiation = 30K

• cSurgery = 50K

TreeAge Pro Healthcare Training – Module 2
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Variables

• Variable Properties View:
• Maintain variables in the tree

• Options to edit, add, delete, categorize, report variables

Edit i E l il bl ith E l M d l (i TP S it )• Edit in Excel available with Excel Module (in TP Suite)

• Variable Definitions View:
• Maintain variable definitions

• Contents change with selected node

• Defined vs. Undefined vs. Inherited

25

• Cut/Copy/Paste to copy or move variable definitions to other 
nodes

TreeAge Pro Healthcare Training – Module 2

Build CE Model

Instructions:

1. Select root node.

2. Select or open the Variable Properties View.

3. Click the “+” icon.

4. Enter the variable name “effEradicated”.

5. Check the box Define numerically at root.

6. Enter 10 in the definition field and click OK.

7. Repeat steps 3-6 for the variable below.
ffN tE di t d 3

26

• effNotEradicated = 3

• pEradicateRad = 0.6

• pEradicateRadSurg = 0.8

8. Replace the 0.6 probability value for the Radiation 
eradicates tumor with the pEradicateRad variable.

TreeAge Pro Healthcare Training – Module 2
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Build CE Model

• At this point, our model should look like this…

27

• We still need to terminate the scenarios for the top 
strategy and build the bottom strategy

TreeAge Pro Healthcare Training – Module 2

Build CE Model

• Information:
• A person’s life expectancy is 10 years if the tumor is 

eradicated, but only 3 years if not

• The costs associated with radiation and surgery are $30K• The costs associated with radiation and surgery are $30K 
and $50K respectively

• The follow-up costs post-treatment are $2K per year

• Model:
• Change tree’s calculation method to cost-effectiveness

28

• Terminate the two scenarios in the top strategies

• Add the appropriate values for cost and effectiveness

• We will break from building the model to discuss tree 
preferences

TreeAge Pro Healthcare Training – Module 2
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Tree Preferences

• Control calculation and display of model
• Many categories

• Menu: Tree > Tree Preferences to open dialog

• Calculation Method:
• Determines which payoff sets will be used to evaluate the 

model and determine the optimal strategy

• Usually either simple or cost-effectiveness

29

• Numeric Formatting:
• Controls display of outputs (calculated payoffs and EVs)

• Set for units, decimal places, labels, etc.

TreeAge Pro Healthcare Training – Module 2

Tree Preferences

• Simple Calculation Method:
• Enter a single payoff at each terminal node

• Single expected value (EV) calculated at all other nodes

Eith i i i i i EV t i k ti l t t• Either maximize or minimize EVs to pick optimal strategy 
at decision nodes 

• Cost-effectiveness Calculation Method: 
• Enter separate payoff values for cost and effectiveness at 

each terminal node

• Cost and effectiveness EVs calculated at all other nodes

30

• Cost and effectiveness EVs calculated at all other nodes

• To select optimal strategy, must balance cost and 
effectiveness, looking at efficiency & tradeoffs

• Will examine further when analyzing finished model

TreeAge Pro Healthcare Training – Module 2
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Tree Preferences

• Not limited to two payoffs (but only two are active)

• Can use extra payoffs for different cost, 
utility/effectiveness, other outcomes

S d l th b d t l bl ith• Same model can then be used to analyze problem with 
different outcome measurements

• Change active payoffs for different measurements and 
repeat analyses

• Cost: Total cost vs. patient cost vs. insurer cost, etc.

• Health/Utility: LY QALY etc

31

• Health/Utility: LY, QALY, etc.

• Other: Positive tests, cases avoided, cases identified, etc.

• Advanced techniques allow for reporting on multiple 
outcomes for certain analyses (terminal columns with 
Node function, calc extra payoffs preference)

TreeAge Pro Healthcare Training – Module 2

Build CE Model

Instructions:

1. Choose Tree > Tree Preferences from the menu.

2. Select the category Calculation > Calculation Method.

3. Select Cost-effectiveness (note active payoffs).

4. Select the category Calculation > Numeric Formatting.

5. Enter settings as seen below.

32

6. Click OK to save the changes.

TreeAge Pro Healthcare Training – Module 2
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Build CE Model

• Terminal nodes terminate the scenario

• Must account for all values that contribute to that scenario 
on the path from the root node to the terminal node

F ff i d l l f• For cost-effectiveness model, enter separate values for 
cost and effectiveness

• For top terminal node…
• Costs:

• Initial Treatment Cost: cRadiation

• Followup Cost: cFollowupAnnual * effEradicated

33

• Effectiveness:
• effEradicated

• For second terminal node…
• Same except using effNotEradicated

TreeAge Pro Healthcare Training – Module 2

Build CE Model

Instructions:

1. Right-click on top node.

2. Choose Change Type > Terminal.
• Edit Payoff dialog opens.

3. Enter expression for Cost:
1. Click ellipsis button to open formula editor for Cost payoff.

2. Select variables to enter the following expression…
• cRadiation + (cFollowupAnnual*effEradicated)

4. Enter expression for Effectiveness

34

4. Enter expression for Effectiveness
1. Type the following expression…

• effEradicated

5. Click OK.

6. Repeat steps 2-5 for second 
terminal node (effNotEradicated).

TreeAge Pro Healthcare Training – Module 2
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Formula Editor/Autofill

• The formula editor is available anywhere you see the 
ellipsis button

• Helps create expressions by providing lists of
M d l i t ( i bl t k t bl di t ib ti )• Model inputs (variables, trackers, tables, distributions)

• Built-in functions (Discount, Round, ProbToProb, etc.)

• Operators (+, -, &&, etc.)

• Keywords (_stage, _trial, _sample, etc.)

• Auto-fill

35

• Press CONTROL+SPACEBAR to automatically complete an 
element of an expression (as listed above)

TreeAge Pro Healthcare Training – Module 2

Build CE Model

• The two strategies are very similar…

• Rather than build the entire bottom strategy from scratch, 
/ h ’ bwe can copy/paste the top strategy’s subtree

• Then we will need to make the appropriate changes to the 
values for the new treatment strategy

36TreeAge Pro Healthcare Training – Module 2
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Build CE Model

Instructions:

1. Select top strategy node.

2. Choose Subtree > Select Subtree from the menu.

3. Choose Edit > Copy from the menu.

4. Select bottom strategy node.

5. Choose Edit > Paste from the menu.

An exact duplicate of the top strategy’s subtree will be 
copied to the bottom strategy.

37

p gy

TreeAge Pro Healthcare Training – Module 2

Build CE Model

Instructions:

1. Change the node labels in bottom strategy from 
“Radiation…” to “Surgery and radiation…”.

2 Ch h b bili f “S d di i2. Change the probability for “Surgery and radiation 
eradicate tumor” node to use pEradicateRadSurg.

3. Change the payoff expressions to include the cost 
cSurgery.

38

• The model is now complete!
• Training model: Example02-Variables.trex

• Training model: Example01-Intro.trex – same but without 
variables

TreeAge Pro Healthcare Training – Module 2
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Variables and Clones

• Before analyzing the model, we will introduce clones

• In our example, we copied the subtree from one strategy 
h hto the other

• What if the subtree was extremely complex and required 
significant revision?

• Clones create exact duplicates of a subtree that stay

39

Clones create exact duplicates of a subtree that stay 
consistent even as the subtree is updated

• We will rebuild the second strategy of our tree using 
clones

TreeAge Pro Healthcare Training – Module 2

Instructions:

1. Open the Example 2 model.

2. Select the New treatment node.

Variables and Clones

3. Choose Subtree > Select Subtree from the menu.

4. Choose Subtree > Delete from the menu.

5. Select the Standard treatment node.

6. Choose Subtree > Create Clone Master from the menu.

7. Enter the name “Treatment outcomes”.

8 S l t th N t t t d

40

8. Select the New treatment node.

9. Choose Subtree > Attach Clone.
The clone copy will be attached.

TreeAge Pro Healthcare Training – Module 2
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• You have now created a clone master and attached a 
clone copy

Variables and Clones

• The clone master is identified by a dark node line and a 
clone index number beneath the node marker

41

clone index number beneath the node marker

• The clone copy is identified with a reference to the clone 
master

TreeAge Pro Healthcare Training – Module 2

• The Clones View allows you to view and edit the clone 
masters and copies

Variables and Clones

• When a clone master is destroyed, all clone copies are 
also destroyed

42

also destroyed

• When a clone copy is destroyed, you can replace it with 
an independent copy of the clone master

TreeAge Pro Healthcare Training – Module 2
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• But we’re not done…

• The values in the clone copy and master are the 
same, so how can we really compare strategies?

Variables and Clones

• Create generic variables in the clone master

• Redefine those generic variables to the left of the clone 
master and clone copies

• This is done in the example 3 model

43

This is done in the example 3 model

TreeAge Pro Healthcare Training – Module 2

• The only two values that need to be different for the clone 
master and clone copy are the probability of eradicating 
the tumor and the cost of treatment

Note that the clone master now uses generic variables

Variables and Clones

• Note that the clone master now uses generic variables

• pEradicateGeneric and cTreatmentGeneric

44

• Those variables are redefined at the strategy nodes
TreeAge Pro Healthcare Training – Module 2
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• Roll back generates the same values for the strategies as 
before the clones (next module)

• Now the treatment outcomes subtrees are linked

Variables and Clones

45

• A Tree Preferences option will eventually allow you to 
expand the clone copy subtree

TreeAge Pro Healthcare Training – Module 2

Analyze CE Model

Module Agenda:

1. Run Back and Expected Value Calculations

2. Cost-Effectiveness Analysis (CEA)

3. Dominance in CEA

4 N t B fit C l l ti

46

4. Net Benefits Calculations

TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

• Expected Value is defined as…
• The sum of: the probability of each possible outcome of the 

experiment multiplied by that outcome’s value (i.e., payoff)

Best estimate for the overall value of the strategy• Best estimate for the overall value of the strategy

• For CE model, cost and effectiveness EVs are calculated 
separately

• Roll back calculates EVs at terminal nodes then 

47

calculates remaining EVs from right to left

TreeAge Pro Healthcare Training – Module 3

Analyze CE Model

• Terminal nodes:
• Calculate the payoff expressions

• Top terminal node…
• Cost: cRadiation + (cFollowupAnnual*effEradicated)

= 30K + (2K * 10) = 50K

• Eff: effEradicated = 10

48

• Path probability:
• Probability of reaching that node within the scenario

• P = 0.600

• Only displayed for optimal strategy
TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

• Chance nodes:
• Weighted average of the node’s branches

• Top strategy/chance node…
• Cost: (0.6 * 50K) + (0.4 * 36K) = 30K + 14.4K = 44.4K

• Eff: (0.6 * 10) + (0.4 * 3) = 6 + 1.2 = 7.2

49TreeAge Pro Healthcare Training – Module 3

Analyze CE Model

• Decision nodes:
• Compare strategies and take optimal path

• In a CE tree, this selects the lowest cost value unless CE 
parameters entered in Tree Preferencesparameters entered in Tree Preferences

• Standard treatment costs less, so it is selected

• CE parameters can place weight on effectiveness relative 
to cost

50

• However, we will compare the strategies using Cost-
Effectiveness Analysis (CEA)

TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

• Cost-Effectiveness Analysis (CEA):
• Standard health economic theory

• Two goals:
O ti i ff ti ( i i ll )• Optimize effectiveness (maximize usually)

• Optimize cost (minimize)

• CEA context:
• Efficient use of limited resources 

• Recommend interventions if additional effectiveness comes at 
a reasonable cost

51

• Calculate Incremental Cost-Effectiveness Ratio (ICER) 
and compare to a willingness-to-pay threshold (efficiency)

• Also sometimes compare to ceiling cost value and 
eliminate strategy if cost exceeds ceiling

TreeAge Pro Healthcare Training – Module 3

Analyze CE Model

• ICER = IC/IE
= (Ccomparator – Cbaseline)/(Ecomparator – Ebaseline)

• In our modelIn our model…
• ICER = ($97.2K – $44.4K)/(8.6LY – 7.2LY)

= ($52.8K)/(1.4LY)
= ~ $37.7K/LY

• To switch from the standard treatment to the new 
treatment, it costs ~ $37.7 for each extra LY 

52

t eat e t, t costs $3 o eac e t a

• If we are willing to pay at least that much per extra LY, we 
can recommend the new treatment

• Now, let’s run CEA in TreeAge Pro

TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

Instructions:

1. Select root node.

2. Choose Analysis > Cost-Effectiveness Analysis from the 
menu.

3. Click Yes.
A Cost-Effectiveness Analysis graph will be created.

4. Click the Text Report link.
The cost-effectiveness calculations are displayed.

53TreeAge Pro Healthcare Training – Module 3

Analyze CE Model

• Cost-Effectiveness Analysis graph:
• Plots strategies on cost and effectiveness axes

• Best options are lower and to the right

• When higher and to the right• When higher and to the right, 
compare on basis of efficiency (ICER)

• Slope of line segment 
is the ICER (IC/IE)

• Will show dominance next

• Edit Chart link allows you 
to modify the appearance 

54

of the graph

• File > Save allows you to 
save either…
• The report and data

• An image of the graph (for publishing)

TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

• Cost-Effectiveness Rankings report:
• Shows IC, IE, ICER calculations

55

• Will show dominance next

TreeAge Pro Healthcare Training – Module 3

Analyze CE Model

• Dominance:
• Some strategies may be dominated when other strategies 

provide better cost-effectiveness

• Dominated strategies are then rejected as treatment• Dominated strategies are then rejected as treatment 
options

• Absolute Dominance:
• The dominated strategy is both…

• Less effective

• More costly

E t d d D i

56

• Extended Dominance:
• The dominated strategy is both…

• Less effective

• Less efficient 
• As measured by an ICER that exceeds an efficiency threshold –

Willingness-to-Pay  (WTP)
TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

• Example 4 model demonstrates both types of dominance

• Same as the tree we built but with three new strategies to 
evaluate

57

evaluate

• Top two strategies collapsed via…
• Subtree > Collapse Subtree

TreeAge Pro Healthcare Training – Module 3

Analyze CE Model

• CEA with dominance

• Line segments create 
cost-effectiveness efficiency “frontier”

R j d i h f i• Rejected strategies are not on the frontier

58TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

• Other Tx 2 rejected by
absolute dominance
• Less effective and

more costly thanmore costly than
Standard Treatment

• Other Tx 3 rejected by extended dominance
M ffi i t t f

59

• More efficient to move from …
Standard treatment to New Treatment (lower ICER/slope) 
than from …
Standard treatment to Other Tx 3 (higher ICER/slope)

TreeAge Pro Healthcare Training – Module 3

Analyze CE Model

• CE Rankings also shows dominance
• Absolute dominance – negative IE and ICER

• Extended dominance – ICER declines

60TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

• But which strategy is preferred?
• Start by rejecting the dominated strategies

• Then compare the ICERs to the WTP value
If WTP $37 7K d St d d t t t• If WTP < $37.7K, recommend Standard treatment

• If $37.7K < WTP < $132K, recommend New treatment

• If WTP > $132K, recommend Other Tx 1

• Note that a total cost ceiling could also reject strategies

61TreeAge Pro Healthcare Training – Module 3

Analyze CE Model

• Note that we can identify the preferred strategy from roll 
back using CE parameters

62

• Optimal strategy identified by Net benefits calculations

• Change to Invert incremental only if effectiveness should 
be minimized (e.g., # of infections or # of deaths)

TreeAge Pro Healthcare Training – Module 3
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Analyze CE Model

• Net Benefits Calculations:
• Build the threshold ICER (WTP) into calculations, as the 

weight on effectiveness, or monetary value per unit of 
additional effectadditional effect
• NMB= (E * WTP) – C

= (LY * $/LY) – $ = $ monetary scale

• NHB= E – (C / WTP)
= LY – ($ / ($/LY)) = LY effectiveness unit scale

• Combine cost, effectiveness and WTP into a single 
measurement which can simply be maximized

63

• Easily seen in roll back on prior page

• Makes graphs that are looking for ICER thresholds much 
clearer
• Example: sensitivity analysis graphs

TreeAge Pro Healthcare Training – Module 3

Deterministic Sensitivity Analysis

Module Agenda:

1. Deterministic Sensitivity Analysis

2. Identify Thresholds

3. 2-Way Sensitivity Analysis and Tornado Diagrams

4 M d li E i

64

4. Modeling Exercise

TreeAge Pro Healthcare Training – Module 4
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Deterministic Sensitivity Analysis

• Sensitivity Analysis studies how a model’s outputs are 
affected by variation in inputs to reflect uncertainty

• Two types of Sensitivity Analysis are supported byTwo types of Sensitivity Analysis are supported by 
TreeAge Pro
• Deterministic Sensitivity Analysis

• How parameter VARIABLES (range) affect outputs

• Covered here

• Probabilistic Sensitivity Analysis
• How parameter DISTRIBUTIONS (samples) affect outputs

65

• How parameter DISTRIBUTIONS (samples) affect outputs

• Covered later

• Both are recalculation “loops”, with uncertain parameters 
changing between recalculations

TreeAge Pro Healthcare Training – Module 4

Deterministic Sensitivity Analysis

Instructions:

1. Open Example 2 tree.

2. Select root node.

3. Choose Analysis > Sensitivity Analysis > 1 Way… from 
the menu.

4. Enter the sensitivity analysis parameters…
1. Select the variable pEradicateRadSurg.

2. Range: 0.5 - 0.9; Intervals: 4.

3. Click OK.

66

3. Click OK.

TreeAge Pro Healthcare Training – Module 4
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Deterministic Sensitivity Analysis

• Generates EV calculations for each value of the variable 
given the range and intervals
• Cost and effectiveness for each strategy

M ltiple graph o tp ts• Multiple graph outputs
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Deterministic Sensitivity Analysis

• x vs. Avg. Eff. shows sensitivity analysis on effectiveness 
only
• Variable on x-axis

Effecti eness on a is• Effectiveness on y-axis

68

• Standard treatment unaffected

• Threshold at pEradicateRadSurg value 0.6
• Thresholds Report

• Beneath 0.6, New treatment is rejected by absolute 
dominance
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Deterministic Sensitivity Analysis

• Sensitivity analysis on cost-effectiveness is more complex
• Need to consider cost, effectiveness and WTP

• Change in relative cost-effectiveness
Ch i d i d/ ffi i• Change in dominance and/or efficiency

• Changes in cost and/or effect ordering

• WTP is our ICER threshold

• How to identify thresholds visually?
• x. vs. ICER graph has challenges

• Net Benefits graph – clearest
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Deterministic Sensitivity Analysis

• x vs. ICER shows how ICER changes with variable

• Output looks odd 
• IE at 0.6 is 0

• ICER value is undefined, 
presented as zero

• With more intervals, 
see asymptote better
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Deterministic Sensitivity Analysis

• Suppose we wanted to identify a threshold for the variable 
based on a WTP of $50K
• We could limit the range and add intervals to get more 

precise valuesprecise values

• We could add horizontal & vertical lines to the graph to 
pinpoint the threshold (Edit Chart)

• Even those options would be problematic with more than 
two strategies

• Use Net Benefits calculations

71

Use Net Benefits calculations 
to combine cost, effectiveness 
and WTP
• Net Benefits link
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Deterministic Sensitivity Analysis

• Net Benefits:
• When prompted for WTP, enter 50K

• Net Benefits calculations combine cost, effectiveness and 
WTP just look for the max valueWTP… just look for the max value

• Graph shows the variable value threshold at which the ICER 
is $50K

• Edit Chart to change 
numeric formatting to 
show more decimal 
places
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Deterministic Sensitivity Analysis

• Net Benefits:
• Thresholds Report also shows the threshold

• Interpretation:
• Based on WTP $50K …

• At variable values below ~0.749, Standard treatment is the 
most cost-effective

0 9

73

• At variable values above ~0.749, New treatment is the most 
cost-effective
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Deterministic Sensitivity Analysis

• 2-way sensitivity analysis:
• See how changing two uncertainties affects recommended 

strategy

• Requires Net Benefits• Requires Net Benefits
• Each axis taken by a variable

• Regions show recommended strategy
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• New treatment favored more with increased difference 
between life expectancy for eradicated vs. not eradicated 

TreeAge Pro Healthcare Training – Module 4



3/22/2011

38

Deterministic Sensitivity Analysis

Instructions:

1. Open Example 2 tree.

2. Select root node.

3. Choose Analysis > Sensitivity Analysis > 2 Way… from 
the menu.

4. Enter the sensitivity analysis parameters…
1. Select the variables:

1. pEradicateRadSurg; Range: 0.5 - 0.9; Intervals: 4.

2. effEradicated; Range 8 - 15; Intervals 7

75

g

2. Click OK.
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Deterministic Sensitivity Analysis

• Tornado Diagram:
• See which variables have the largest impact on EV through 

a series of 1-way sensitivity analyses

• Uses Net Benefits with additional option for ICER• Uses Net Benefits with additional option for ICER

• Be careful:
• Do not overanalyze these graphs

• Details from 1-way sensitivity analyses are not fully presented 
in tornado diagram
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Modeling and Analysis Exercise

• Model description:
• Evaluate a new arthritis drug vs. an existing drug

• Root decision node

Both dr gs are effecti e ho e er the e isting dr g is highl• Both drugs are effective; however, the existing drug is highly 
effective in 70% of cases while the new drug is expected to 
be highly effective in 82% of cases

• Unknown event in each strategy with probabilities

• The cost of the existing drug is $1,000 per year, while the 
planned price of the new drug is $1,500 per year

• Component of cost payoffs

77

Component of cost payoffs

• The utility value for cases treated highly effectively is 0.9, 
but only 0.8 for cases treated effectively

• Component of effectiveness payoffs

• The life expectancy for the cohort is 15 years
• Component of both payoffs
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Modeling and Analysis Exercise

• Analysis Questions:
• Can we recommend the new drug based on a WTP of 

$50K?
• Cost effectiveness analysis yes• Cost-effectiveness analysis yes

• What is the minimum percentage of cases that are treated 
highly effectively such that we can recommend the new 
drug?

• Sensitivity analysis 0.8

• What is the maximum price that could be charged where the 
new drug could still be recommended?

78

g
• Sensitivity analysis $1,600
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Probabilistic Sensitivity Analysis

Module Agenda:

1. Monte Carlo Simulation

2. Distributions

3. Probabilistic Sensitivity Analysis
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Probabilistic Sensitivity Analysis - MC

• Monte Carlo Simulation:
• TreeAge Pro supports several forms of simulation

• Probabilistic Sensitivity Analysis
• Samples: 2nd order parameter uncertainty• Samples: 2nd-order, parameter uncertainty

• Microsimulation
• Trials: 1st-order, individual variability

• Two-Dimensional
• Samples & Trials

• Three-Dimensional
• Partial EVPI

80

• Stored analyses can run simulations in batches
• Analysis > Stored Analyses  Tree Preferences

• We will focus on Probabilistic Sensitivity Analysis within this 
training module
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Probabilistic Sensitivity Analysis

• Probabilistic vs. Deterministic Sensitivity Analysis

Deterministic Sensitivity Analysis Probabilistic Sensitivity Analysis

Variables Distributions

Calculate EV based on 
range/intervals for uncertain inputs

Calculate EV based on random 
samples for uncertain inputs

Repeating gives same results Repeating yields different results 
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p g g p g y
from different sampled input values

Usually only 1 uncertainty at a time 
(2 and 3 available)

All uncertainties sampled 
simultaneously

Probabilistic Sensitivity Analysis

• Advantages of PSA over Deterministic SA
• More robust

• More parameters

M l l ti• More recalculations

• More interpretation
• Confidence intervals, value of information, etc.

• Non-PSA applications of Monte Carlo simulation with 
sampling:
• Non-linear models, parameters

82

• Roll back EVs (using distribution means), might not be the 
same as simulation mean results (due to non-linearitiy)…

• In this case, the mean from the sampling simulation is a better 
estimate of EV than rollback using estimates/means

• If distribution means are not the same as original estimates, 
EV calculations will be different
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Probabilistic Sensitivity Analysis

• Requires defining parameters using probability 
distributions instead of simple variables
• Only parameters you want to study via PSA need 

distributionsdistributions

• Calculation Loop: 
• Sample parameter value from each distribution

• Calculate expected value for tree using sampled values

• Repeat for predefined number of samples

83

• Examine set of resulting EVs
• Mean/median of EVs

• Distribution of EVs

• High/low EVs

• Confidence intervals
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Probabilistic Sensitivity Analysis

• We will start with the Example 02 model
• Open and save under new name

W ill i d di ib i• We will introduce distributions to measure parameter 
uncertainty for…
• Probability of eradicating tumor with standard treatment

• Probability of eradicating tumor with new treatment

• Cost of surgery
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Probabilistic Sensitivity Analysis - Distributions

Instructions:

1. Choose Views > Distributions from the toolbar.

2. Click the “+” icon in the Distributions View to create a new 
di ib idistribution.

3. Enter the distribution information 
as seen at right:
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Probabilistic Sensitivity Analysis

• Distribution type and parameters define the shape of the 
distribution

• Each distribution type requires 
specific parameters

Probabilistic Sensitivity Analysis - Distributions

specific parameters
• Example: normal type has a mean 

and standard deviation

• Analysis required to determine 
appropriate and parameters for
your model’s uncertainties

86

your model s uncertainties
• This can be difficult
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Probabilistic Sensitivity Analysis

• Common distribution types:
• Normal

• Standard bell curve

• Uniform

Probabilistic Sensitivity Analysis - Distributions

• Equal likelihood of all values in range

• Option to limit to integers

• Beta
• Frequently used for probabilities

• Restricted to between 0 and 1

• Triangular
• Provide min, max and most likely

• Dirichlet

87

• Dirichlet
• Sample multiple complementary probabilities, like interrelated betas

• Table
• Sample from “empirical” data:

• Table with columns for  “values” and corresponding probability

• Will cover in detail during Microsimulation
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Probabilistic Sensitivity Analysis

• Distribution index and name:
• Can reference distribution in the model by either

• Recommend references by name

Certain distrib tion f nctions req ire reference b inde

Probabilistic Sensitivity Analysis - Distributions

• Certain distribution functions require reference by index
• Example: DistForce(index), DistTrim(index; min; max)

• Parameter approximation:
• Certain distribution types’ parameters can be approximated 

from other statistics

• In our first distribution, we estimated the Alpha and Beta 
parameters from the mean and standard deviation

88

parameters from the mean and standard deviation

• Sampling rate:
• Use Resample per EV/group of trials for PSA parameter 

uncertainty; parameter affects entire cohort

• Other options for individual variability among trials
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Probabilistic Sensitivity Analysis

• Graph distribution to test:
• Mimics sampling that will

be performed during PSA

Probabilistic Sensitivity Analysis - Distributions

• Samples centered around mean (0 6) with variation

89

Samples centered around mean (0.6) with variation
• Beta is not a normal bell curve
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Probabilistic Sensitivity Analysis - Distributions

Instructions:

1. Open/select the Distributions View.

2. Click the “+” icon in the Distributions View to create a new 
di ib idistribution.

3. Create two more distributions…
1. dist_pEradicateRadSurg

• Beta parameters approximated from mean 0.8 and std dev 0.1

2. dist_cSurgery
• Normal distribution with mean 50,000 and std dev 10,000
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Probabilistic Sensitivity Analysis

• Distributions created, but they need to be integrated into 
the model

• Two options…
R l f t i bl ith f t

Probabilistic Sensitivity Analysis - Distributions

• Replace references to variables with references to 
distributions

• Define variables using distributions rather than numeric 
values
• Can still run deterministic sensitivity analysis
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Probabilistic Sensitivity Analysis - Distributions

Instructions:

1. Select the root node.

2. Open/select the Variable Definitions View.

3. Redefine the following three variables…
1. cSurgery = dist_cSurgery

2. pEradicateRad = dist_pEradicateRad

3. pEradicateRadSurg = dist_pEradicateRadSurg
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Probabilistic Sensitivity Analysis

• Non-PSA calculations will use mean values for 
distributions (no sampling)
• Since we setup our distributions with means equal to the 

original numeric estimates our roll back and CEA results

Probabilistic Sensitivity Analysis - Distributions

original numeric estimates, our roll back and CEA results 
will not change

• This is not always the case, so be careful with non-PSA 
analysis
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Probabilistic Sensitivity Analysis - Distributions

Instructions:

1. Select the root node.

2. Choose Analysis > Monte Carlo Simulation > Sampling.

3. Enter 1000 samples.

4. Click Begin.

• We ran 1000 iterations
• How many do you need?

• Depends on number of distributions and complexity

94

• Depends on number of distributions and complexity 
of model

• If successive simulations generate same mean and std dev 
for each strategy  enough iterations
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Probabilistic Sensitivity Analysis

• After PSA simulation completes…
• Statistics are displayed for each strategy

• Cost, effectiveness, and NMB (using WTP from prefs)

Li k t i f t d h

Probabilistic Sensitivity Analysis - Distributions

• Links to a series of reports and graphs
• We will look at a few

• How do we interpret results?
• We now have N separate EV

calculations

95

• Need to review these EV calcs
balancing each strategy’s 
cost and effectiveness 
with our overall WTP
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Probabilistic Sensitivity Analysis

• Monte Carlo simulation output can be saved as *.rptx file 
for review later

• Selected PSA output options

Probabilistic Sensitivity Analysis - Distributions

Selected PSA output options…
• Values, Dists, Trackers: Shows each strategy’s EV 

calculations and distribution samples for each iteration

• Output Distributions: Shows distribution of EV outputs for 
each strategy or for incrementals
• ICER distribution can be interesting, but also can be difficult in 

cases where IE can be zero (wild fluctuation in ICER)
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• CE Analysis: CEA from simulation means
• ICER may not match regular non-PSA CEA ICER

• CE Scatterplot: Shows scatter of each iteration’s cost and 
effectiveness values for each strategy

• More…
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Probabilistic Sensitivity Analysis

• Selected PSA output options (continued)…
• ICE Scatterplot: Compares a pair of strategies showing IC 

and IE on graph
• Edit graph to change y axis scale to include zero

Probabilistic Sensitivity Analysis - Distributions

• Edit graph to change y-axis scale to include zero
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• Want to be below and to the right of the WTP line

• Components 1, 2, 5 recommend new treatment

• Overall 64.5% of iterations recommend new strategy

• Measure of our confidence in recommendation

Probabilistic Sensitivity Analysis

• Selected PSA output options (continued)…
• CE Acceptability Curve: Shows the 

percentage of iterations that favor 
each strategy over WTP range

Probabilistic Sensitivity Analysis - Distributions

each strategy over WTP range
• Shows same percentage as ICE

scatterplot, but easier to see using
Net Benefits

• Added line via Edit Chart options

• Strategy Selection Frequency: Shows 
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the percentage of iterations that favor 
each strategy for a single WTP
• Should change y-axis to start at 0, 

looks misleading as is
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Course Agenda
Day 1 is complete!!!

Day 2

1. Markov Models

2. Time Dependence & Tables in Markov Models

3. Extra Markov Options

4. Microsimulation & Trackers

5. Bootstrapping with Patient Data
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6. Decision Trees & Microsimulation Models

7. Two-Dimensional Simulations

8. Getting Help
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